Experiencing issues opening some studies.
Incident Report for Castor
Resolved
This incident has been resolved
Posted Apr 07, 2024 - 09:59 CEST
Monitoring
The issues should be solved, we are continuing to monitor.
Posted Apr 07, 2024 - 09:24 CEST
Investigating
We are currently experiencing issues opening some studies.
Posted Apr 07, 2024 - 03:46 CEST
This incident affected: Castor EDC (🇳🇱 NL Server - data.castoredc.com).