US database maintenance
Incident Report for Castor
Resolved
Database maintenance has been completed
Posted Oct 24, 2023 - 11:33 CEST
Identified
Our hosting provider is performing scheduled maintenance on our database servers in the US region. As a result of this, studies on CDMS US are currently unavailable.
Posted Oct 24, 2023 - 11:07 CEST
This incident affected: Castor EDC (🇺🇸 US Server - us.castoredc.com).