Form Sync unable to create linked studies
Incident Report for Castor
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 08:56 CEST
Monitoring
We've deployed a new configuration that should resolve the problem for the time being, but we'll continue to monitor closely.
Posted Apr 10, 2024 - 23:02 CEST
Update
Our investigation is leading to an underlying infrastructure problem with our hosting provider. We'll continue investigating the problem.
Posted Apr 10, 2024 - 16:46 CEST
Update
We are continuing to investigate this issue.
Posted Apr 10, 2024 - 15:03 CEST
Investigating
It's currently not possible to create linked studies with Form Sync.

We are investigating the issue
Posted Apr 10, 2024 - 11:44 CEST
This incident affected: Castor EDC (🇳🇱 NL Server - data.castoredc.com, 🇬🇧 UK Server - uk.castoredc.com, 🇺🇸 US Server - us.castoredc.com, 🇦🇺 AU Server - au.castoredc.com) and Castor EDC - Private Cloud.