EDC service disruption
Incident Report for Castor
Resolved
This incident has been resolved.
Posted Nov 07, 2023 - 22:58 CET
Update
The issue has been acknowledged by our hosting provider Microsoft Azure. They are currently investigating mitigation options.
Posted Nov 07, 2023 - 14:52 CET
Update
We are still investigating the issue and are in contact with our hosting provider.
Posted Nov 07, 2023 - 14:17 CET
Investigating
We are investigating an increased rate of errors and possible outage on our EDC platform.
Posted Nov 07, 2023 - 13:57 CET
This incident affected: Castor EDC - Private Cloud.