Degraded performance

Incident Report for Castor

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 21:07 CET

Investigating

We are currently investigating this issue.
Posted Feb 25, 2025 - 20:54 CET
This incident affected: Castor EDC (🇬🇧 UK Server - uk.castoredc.com).