CDMS not available in US regions

Incident Report for Castor

Resolved

We have implemented and deployed a fix, and all environments are fully operational again. We're marking this incident as resolved.
Posted Nov 26, 2024 - 12:13 CET

Identified

We are currently investigating an outage in our CDMS US regions. We have identified the reason and are working on a fix. We expect an update in 30 to 45 minutes.
Posted Nov 26, 2024 - 11:18 CET
This incident affected: Castor EDC - Private Cloud and Castor EDC (🇺🇸 US Server - us.castoredc.com).