Service has remained stable, we are closing this incident as resolved. We will continue investigating the contributing factors that caused the failure in order to improve our reliability in the future. Our apologies for the inconvenience.
Posted Jul 23, 2025 - 19:21 CEST
Monitoring
Connectivity to the central user database has been restored and all services are back up and running. We'll monitor the environments for the coming 60 minutes before we will close this incident.
Posted Jul 23, 2025 - 18:07 CEST
Identified
We have identified a problem with the primary user database for the EU region and are working to restore its function.
Posted Jul 23, 2025 - 16:56 CEST
Update
We are continuing to investigate this issue.
Posted Jul 23, 2025 - 16:28 CEST
Investigating
We are currently investigating intermittent availability issues of our CDMS NL and UK environments.
Posted Jul 23, 2025 - 16:14 CEST
This incident affected: Castor EDC (🇳🇱 NL Server - data.castoredc.com, 🇬🇧 UK Server - uk.castoredc.com) and Castor SMS.