Partial outage EDC - Public Cloud
Incident Report for Castor
Resolved
The incident has been resolved.
Posted Nov 16, 2022 - 12:33 CET
Monitoring
A fix has been implemented and we will keep monitoring the application.
Posted Nov 16, 2022 - 12:08 CET
Identified
The issue has been identified and we are working on a solution.
Posted Nov 16, 2022 - 11:32 CET
Investigating
We are currently investigating an issue where a limited amount of studies are unavailable.
Posted Nov 16, 2022 - 11:18 CET
This incident affected: Castor EDC (🇳🇱 NL Server - data.castoredc.com).