Some users are unable to log in to Castor

Incident Report for Castor

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 20:07 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 05, 2026 - 17:33 CET

Update

We have further narrowed down the scope of this issue and determined that this only affects users in CDMS located on our NL instance.
Posted Mar 05, 2026 - 17:08 CET

Investigating

We are investigating an issue that affects a small subset of our users, preventing them from logging in. Despite having a valid user account, affected users will get an "Email address not recognized" error that prevents them from logging in.
Posted Mar 05, 2026 - 16:18 CET
This incident affected: Castor EDC (🇳🇱 NL Server - data.castoredc.com, 🇬🇧 UK Server - uk.castoredc.com, 🇺🇸 US Server - us.castoredc.com, 🇦🇺 AU Server - au.castoredc.com) and Castor eConsent (🇺🇸 US Server - us.castorconsent.com, 🇪🇺 EU Server - eu.castorconsent.com, manage.castorconsent.com).