This incident has been resolved. Email delivery to Microsoft-hosted addresses has been fully restored.
Posted Feb 25, 2026 - 21:37 CET
Monitoring
We have identified the root cause and switched to a backup email provider. Email delivery to Microsoft-hosted addresses has been restored and we are monitoring the situation.
Posted Feb 25, 2026 - 21:27 CET
Identified
We are currently investigating email delivery issues affecting recipients with Microsoft-hosted email addresses (hotmail.com, outlook.com, live.nl and similar domains). Some users may not have received emails sent by Castor, including survey invitations and system notifications.
We are actively working on a resolution and will provide updates as the situation develops.
Only EU region appears to be affected.
Posted Feb 25, 2026 - 20:51 CET
This incident affected: Castor EDC (🇳🇱 NL Server - data.castoredc.com, 🇬🇧 UK Server - uk.castoredc.com) and Castor EDC - Private Cloud.