Emails/Survey notifications are currently not being delivered

Incident Report for Castor

Resolved

This incident has been resolved.
Posted Nov 26, 2024 - 19:18 CET

Monitoring

The backlog of e-mails/survey notifications has been processed and we are monitoring the situation.
Posted Nov 26, 2024 - 16:14 CET

Identified

Issue has been identified and we're working on a fix for it
Posted Nov 26, 2024 - 15:04 CET

Investigating

We are currently investigating the issue.
Posted Nov 26, 2024 - 14:26 CET
This incident affected: Castor EDC (🇳🇱 NL Server - data.castoredc.com, 🇬🇧 UK Server - uk.castoredc.com), Castor eConsent (🇺🇸 US Server - us.castorconsent.com, 🇪🇺 EU Server - eu.castorconsent.com), and Castor EDC - Private Cloud.