Some participants cannot pass the personal details page
Incident Report for Castor
Resolved
This incident has been resolved.
Posted Sep 28, 2023 - 17:52 CEST
Monitoring
We've reverted the app to a previous version and we're continuing the investigation on testing environments
Posted Sep 28, 2023 - 17:35 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 28, 2023 - 17:20 CEST
Investigating
We are currently investigating this issue.
Posted Sep 28, 2023 - 17:15 CEST
This incident affected: Castor eConsent (🇺🇸 US Server - us.castorconsent.com, 🇪🇺 EU Server - eu.castorconsent.com).